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Creating Mailing Labels in Apache™ OpenOffice

We will be using Apache™ OpenOffice, which is available as donation-ware from 
www.openoffice.org to create mailing labels.  Mail merge procedures vary a great deal. 
The techniques will need to be adapted if you are using something other than 
OpenOffice. Although snail mail is slowly giving way to email, there are many 
circumstances where you need to do an old fashioned mailing.  That is especially true for 
the 55+ generation, where internet access and email addresses are not universal.  

Purchasing the labels
Buy labels that match your printer.  Inkjet labels for inkjets, laser for laser 
printers.  Using an inappropriate type of labels, can cause damage to your printer! 
Heed any warnings about restrictions regarding refeeding a label sheet into a 
printer.  Use the paper tray/path that your printer manual recommends for labels.  
The last thing you want to do is have your labels peel off there backing and gum 
up the works inside your printer!

Guidelines for Creating an Address Book Spreadsheet.
Each row of the spreadsheet represents a record.  Each address will occupy one 
row or record in your spreadsheet.  

The data in each column is known as a field.  Break fields apart when you create a
spreadsheet.  It is a lot easier to automatically concatenate (put thing together) 
than it is to automatically break compound fields apart.  For example instead of 
using Name, consider separating Name into First and Last.  Instead of using 
Address3, use City, State, Country and Postal Code in separate columns.   You’ll 
often want to sort a list by Country, Postal Code or Last name and it is so much 
easier if you create your spreadsheet database with this in mind.

Use the first line of the spreadsheet to give meaningful names to the columns or 
headers.  As a best practice: 
 Make each heading name unique.  
 Start each header with a letter (i.e. Address1 not 1Address).
 Don’t include special characters or spaces in the header name.
 Limit names to 10 characters in length, as some software suites don’t support 

longer field names.
 Use meaningful names that identify the data because when you create your 

column header, because you will not be able to see the data while you layout 
your label.

 Adjust the column width so that the widest data field is visible.
 Format the zip code column as text so that leading zeros are visible.
 Format the Print Range to repeat the heading row on each printed page.
 Change  the Print Page format to be landscape and be only 1 page wide
 Split the data window so that the headings stay visible data while entering your

data.
 Sort the data in the order you want to print.
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Exercise Creating a Spreadsheet.
Start OpenOffice

 Open the address book.
File->Open>ClassExamples ->Sample Addresses.ods
 Adjust the column width so that the widest data field is visible

1. Click on the line between the column labels and drag until the data shows
 Format the zip code column as text so that leading zeros are visible.

1. Highlight Cells H2:H100 
2. Select Format->Cells from the menu
3. On the General tab select Text from the Categories
4. Press OK 
5. Correct the first two zipcodes by adding a leading zero

 Format the Print Range to repeat the heading row on each printed page
1. Select  Format->Print Range ->Edit from the menu
2. In the Rows to Repeat area
3. First box should say –user defined-
4. Second box should say $1
5. Click OK

 Change the Page layout to be landscape
1. Select Format->Page from the menu
2. Select the Sheet tab
3. In the Scale section change the scaling mode to be “fit print ranges to 

width height”
4. Change the width in pages to be 1
5. Change the Height in pages to be 10
6. Click OK

 Split the data window so that the headings stay visible
1. Scroll to the top of the page
2. Select cell A2
3. Select Window->Split from the menu.
4. Scroll to the bottom of the spreadsheet.
5. Add a line with your name and address

 Sort the data in the order you want to work with
1. Select all the data cells to sort.  In this case A1:L39.  If you don’t get all 

the columns, you’ll have mismatched data when your sort is complete!!!.
2. Select Data->Sort from the menu.
3. Select the Options tab
4. Check the box that say “Range Includes Labels”
5. Select the Sort Criteria tab.
6. Change “Sort by” to be Last.
7. Change “Then by” to say First.
8. Click OK.

 Save your file
1. Select File->Save from the menu.

 Exit OpenOffice
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Part 2: Registering a Spreadsheet as a Data Source

OpenOffice is able to use many types of data connections we are using spreadsheets, but 
other formats including text files, Microsoft® Outlook Address book, Microsoft® 
Windows Address Book, Microsoft® Access, Microsoft® Access 2007, and. Mozilla 
Thunderbird Address Book are supported as well as more geeky sources such as ADO, 
ODBC, .MySQL….

We are using a spreadsheet for our database.  You edited and saved the “Sample 
Address.ods” spreadsheet.  (If you are following along at home, you can download the 
Sample Address spreadsheet from my website)

Now you need to register the spreadsheet as a data source.  

If your data is in a spreadsheet, follow these steps. 

1. Choose File > New > Database. 
2. Select Connect to an existing database, 
3. Select Spreadsheet as the format. 
4. Click Next. 
5. Specify the spreadsheet file. Each sheet in that spreadsheet will be a table in your 

database. 
6. Click Next. 
7. Unmark the option to open the database for editing. You can open it; you just do 

not have to. 
8. Click Finish. 
9. Save the data source (aka database) under a name that will help you remember 

what it is. For class use “MyBook”
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Part 3. Creating and Printing Labels

1. Once you have got the database set up in OpenOffice you are ready to go. 
2. Choose File > New > Labels. 
3. In the Labels tab of the Labels window, select the database you created in step 2. 

Note: You are looking for the name of the database you created, which should be 
“MyBook”, not the spreadsheet containing the data.  

4. Select a table from the Table list. This will be Sheet1 in our case.. 
5. Select the first field you want to use from the Database field list and click the big

arrow in the middle of the window to insert it in the Label text field. 
6. Use the Database field list to insert any other fields you need. Type a space after 

the field and you can add the next field, such as Last. If you want fields on the 
next line, position the cursor after the last character on the current line, and just 
press Enter on the keyboard. If you need to change the arrangement later in the 
created label document, you can. 

 Select Title from the database field, click the arrow, push the spacebar on the 
keyboard, select First, click the arrow, press the spacebar on the keyboard,  select 
Last, click the arrow, press the Enter key on the keyboard 

 Select Address1, click the arrow, press the Enter key.
 Select Address2, click the arrow, press the Enter key.
 Select City, click the arrow, type a comma (,), press the spacebar, select State, 

click the arrow, press the spacebar, select ZipCode, click the arrow, press the 
Enter key

 Select Country click the arrow
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 Make sure you know the brand, product 
number and  size of the  label you are 
printing on, because all programs will 
require this information.  OpenOffice has 
options for entering the product number for
labels from various companies, in place of 
entering the label size. This takes the 
guesswork out of printing and makes it 
easier for you to print labels correctly. 
Some label makers also provide their own 
software for printing labels. 

We will assume we are using these Avery 5961 labels that come on 8.5x11 inch stock.

7. In the Brand dropdown list, if your Avery labels come on 8.5”x11” sheets, select 
Avery Letter Size as your brand.. 

8. In the Type dropdown list, scroll to the one that matches the packaging on your 
labels.  Choose 5961 Address as shown on the packaging. 

9. Click the Options tab. 
10. Check the Synchronize contents option.  This allows you to apply formatting, 

like a different font or colors or adding graphics, fixing spacing and make those 
changes apply to all of your labels with the click of a button

11. Click the Setup button next to the printer display. 
12. Select the printer you want to print to. 
13. In the printer options (this will vary according to your operating system) specify 

the appropriate paper feed or tray. For now, select Manual Feed. 
14. Click the New Document button at the bottom of the window. The labels will 

appear. You will not see the data, you will see the field. 
15.  If you need to make changes, like adding spaces, rearranging fields, or changing 

formatting, do so in the upper left label. Then click Synchronize Labels to apply 
those changes to all labels. 

16. Choose File -> Print 
17.  You will see a message asking you whether you want to print a form letter. Click 

Yes.
18. ! Do not mark a checkbox saying you do not want to see the message again!. This 

checkbox is gone on OpenOffice 4.0.1, but was a problem in earlier versions  
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This process often takes a few tries to get it right..  At this point I’d recommend printing 
to a file instead of the printer.  You can then select File->Open and then locate the file 
you just created.  That way you won’t have to waste any paper trying to get it right.  

19 Click File
20 Click Save as a single file
21 Click Ok 
22 Type a file name in the box provided, let’s use Test as our file name.
23 Click Save
24 If you are warned that the file already exists, click Yes to overwrite any 

previous versions.  

To view your work
1. Select File->Open
2. Type in Test.odt in the filename box
3. Click Open
4. Check your work and close the window.

You can save the label document and just go back to it again when you need to use it 
again. 

You can print to a file and then open that file to see your merged document without 
actually printing it.
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 Suppressing Blank Lines
Sometimes our labels have 2 lines in an address, sometimes there isn’t a second line.  Our
form needed to include it, but as a result some of our labels had a blank line.
<Title> <First> <Last> 
<Address1> 
<Address2> 
<City>, <State> <Country> <ZipCode> 

This looks rather sloppy, so we are going to change the label to scrunch up the label, if 
there is nothing in line 2.  

Marilyn Monroe James Northrup 
444 East 57th Street 2201 Broadway
Apartment 13E New York, NY 10024 
New York, NY 10022-3515  

1. If you don’t have the Untitled document, with the labels visible,  Make sure you 
have a registered your spreadsheet as a database, and created the label sheet with 
the  File > New > Labels, on the previous section. Select your database and 
tables, insert the fields, and then check the Synchronize Contents checkbox on 
the Options tab.. Click New Document. The labels will appear. 

What we are going to do is replace some soft returns with hard returns as shown here.  
Take a good look at the picture below.  See the ¶ at the end of the Address1 and 
Address2 line in the upper left label.  We are going to put them there on your document..

2. Turn on nonprinting characters if they are not on already, by choosing View > 
Nonprinting Characters, or by clicking on the ¶ symbol on the toolbar.
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3. Position your cursor after the <Address1> then press the Delete key, then press 
the Enter key. 

4. Position your cursor after the <Address2> then press the Delete key, then press 
the Enter key. 

5. Click the  Synchronize Labels to update the other labels to be the same. 
6. Now that there are the ¶ marks are in place we are going to create a hidden 

section.  In order to do that we need to know the long name of Address2 that 
contains its databasename, tablename and fieldname.  This is going to be case 
sensitive, that means that you must match the name exactly the way you typed it 
in.  Don’t remember what you did?.  Just hover over Address2 field and the full 
name will be revealed.  Please note this, because for the next step to work, you 
will need to type this exactly correctly.    

7. Select the <Address2>¶ field complete with the ¶.  To do this, locate your 
cursor  beginning of the <City> line, and drag highlight up to the beginning or the
<Address2> line  . 

8. Choose Insert -> Section from the menu . 
9. Name the new section Suppress. Check the Hide checkbox . and then fill in the 

With Condition box with the full field name that that you noted in step 6 
followed by a space, the letters EQ another space and two quotation marks.  If 
you followed the instructions your with condition should be:

MyBook.Sheet1.Address2 EQ  ""
Note: If you are using a data source that allows spaces enclose the field with [ ] 

[databasename.tablename.fieldname] EQ  ""

Your screen should look like this

10. Click Insert. 
11. Delete the ¶ that is between the Address 2 line and the City state and zip.
12. Click Synchronize Labels. 
13. Now print your data, by selecting File->Print
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This process often takes a few tries to get it right..  At this point I’d recommend printing 
to a file instead of the printer.  You can then File->Open and then locate the file you just 
created..  That way you won’t have to waste any paper trying to get it right.  

14. You will see a message asking you whether you want to print a form letter. Click 
Yes.

15. Click File
16. Click Save as a single file
17. Click Ok 
18. Type a file name in the box provided, let’s use Test as our file name.
19. Click Save
20. If you are warned that the file already exists, click Yes to overwrite any previous 

versions.  

To view your work
1.  Select File->Open
2.  Type in Test.odt in the filename box
3.  Click Open
4.  Review your work and then close the window

If you need to change the section, select it in the first address and choose Format > 
Section. Select the one named Suppress for the master label and make changes, then 
clickTo Make the Data Source (Text File Instructions)
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Printing on the Labels

Practice printing labels on a plain sheet of paper before you print on an actual label sheet.
This can save you lot of time, money and frustration. After you setup the label with your 
text, the next step is to figure out what direction to feed the blank envelopes or label 
sheets into your printer. Should you feed them face up or down, and which direction 
should you rotate them? It is easy to determine this by writing an x in the corner on the 
first sheet of paper in the tray, so you’ll know which side is the up depending on if the x 
is on the printed side or on the back of your test labels.  After you print a paper test, place
it on top of a blank label sheet and hold them up to a bright light to see if the text aligns 
to the labels.  If it matches you are ready to go except you’ve got those funky blank lines 
on your labels that have only 1 address line that we will deal with on the next page.

It is important to know what type of printer you have and the printer’s recommendations 
for paper path.

We have a networked laser printer in the lab.

IMPORTANT Laser Printer Guidelines

 Only use labels recommended for laser printers.
 Verify that the labels’ adhesive material can tolerate fusing temperature of 205°C 

(400°F) for 0.1 second.
 Make sure that there is no exposed adhesive material between the labels. Exposed 

areas can cause labels to peel off during printing, which can cause paper jams. 
Exposed adhesive can also cause damage to printer components.

 Do not feed a sheet of labels through the printer more than once. The adhesive 
backing is designed for one pass through the printer.

 Do not use labels that are separating from the backing sheet or are wrinkled, 
bubbled, or otherwise damaged.

Typically labels need to be fed through the route on the printer on a path that the sheet is 
not bent.  Here is the procedure for printing labels with our laser printer

1. Open the front Multi-Purpose Tray and the rear output tray.
2. Load labels in the multi-purpose tray with the print-side up.
3. Adjust the guide to fit the width of the sheet of labels without squeezing them.
4. When you print on labels, select the appropriate paper source, type, and size in the

software application. 
5. After printing, close the Multi-Purpose Tray and the rear output tray.
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Mail Merge Window Controls

Right about now you may be thinking, why not just type out the addresses.  The Mail 
Merge window is a powerful tool.  We are going to play with the tools to give you a 
sense of powerful and how easy these are to use.  Remember you got here by printing the 
labels, and then choosing to process this as a form letter.   

Mail Merge Window 

You can see in the Records area that we can print All the labels, selected records or a 
range From row x to z.

Selecting a continuous range visually.  Click on the gray box at the beginning of the 
first row you want to print. The line will turn color, indicating it is selected.  Scroll down 
to the last row you want to print.   Hold the Shift key down and click on the gray box at 
the beginning of the last box 

OpenOffice also sorts controlled selection.  Click on the gray box at the beginning of the
first row you want to print.  The line will turn color, indicating it is selected.  Scroll down
and hold the Ctrl key while you click on the gray box of each row you want to print 

Controlled selection
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Filters

Filtering is another way to limit which records are going to be printed. The Mail Merge 
window offers you access to easy to use powerful filters. The little funnels on the toolbar 
are the filtering tools. 

Auto Filter 
To use the auto filter, simply click on the value you want to match abd then click on the 
icon.  
Exercise: 

 Scroll until you find a row where the state is California, “CA”,  
Click on a the “CA”
Then click on the AutoFilter icon on the toolbar
Boom, only lines with the CA in the state field are available for printing.

Clear Filter
To remove the current filter, simply click on the Clear Filters icon on the toolbar.

Apply Filter  
Apply filter toggles the filtered state on and off.

Standard Filter
The standard filter lets you build more complicated filters.  It will bring up a Standard 
Filter window where you can build more complicated conditions.  Conditions are a little 
too abstract to cover in the class, but I wanted you to know you have these types of 
options available to you.
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Sorting:

Although people tend to like working with data in alphabetical order, you might want to 
print labels in some other order.  Open Office’s Mail Merge window makes sorting your 
data very easy.

Ascending Sort 
The ascending order sort is probably the most common.  Click on the field you want to 
sort and then click the ascending sort icon.  Your rows will be arranged alphabetically by 
the contents of that column.

Descending Order
The descending order sort, works just like the ascending sort, only the rows are arranged 
in reverse order from z to a.

Sort
The custom Sort, displays a “Sort Order” dialog window that lets you order your rows 
based on multiple criteria.  For instance the sort shown below lets you arrange rows by 
last name and then first name.  

Sort yields a sort where last name, first name order...
 
 Mary Smith

Sam Smith.
Ann Smithe
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Bonus material

Creating and Saving a Database Query for Mail Merge.

There are many times you’ll want to print a subsection of your address book spreadsheet. 
You can do this from the Mail Merge window as we showed you earlier.  If you need to 
make a huge series of adjustments in the Mail Merge window and you need to do it often,
you can automate this process by creating a query.  A query is a way of asking the 
database some questions.  A query  creates a dynamic list that will change as your data 
changes.

1. From OpenOffice’s s text editor press F4 to open the Database Source window 

2.  Right click on the Queries folder under your “MyBook” database connection/
3. Click on the Edit Database File option
4. Click on the Queries icon in the left database panel
5. Click on Create Query in Design View. in the Tasks panel
6. In the Add Tables popup, select Sheet1 and click Add
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7.

We are going to fill in the sheet exactly as shown above.

8. First column select Sheet1.* as the field, that means select all the columns of data 
and they are visible.

9. The second column has Country, is not visible, and has a Criterion of “IS EMPTY”
so it will show all the rows in the original database that do not have an entry in the 
country field. (See Help on Queries to see what kind of criteria are allowed)

10. The third column has ZipCode, it is not visible, and the Sort order is selected as 
ascending.  This will make the results show and print in ZipCode order.

11. Select File->Save from the menu.
12. Change the Query name “USOnly”
13. Click OK
14. Close the window 
15. Click Save if asked
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Now recreate the labels from the start, except instead of choosing Sheet1 for the table, 
select “USOnly” as the table name.

1. Select File ->New->Labels from the menu
2. Change the database to MyBook
3. Change the table to USOnly
4. Delete all the label text in the right hand panel
5. Recreate the label as shown in Part 3;
6. Save your labels.

Summary
There you have it.  I have just communicated everything I know about creating mailing 
labels.  The techniques you have just mastered also work with form letters and envelopes 
as well as mailing labels.  Mail merge procedures vary greatly from one software package
to another, the techniques will need to be adapted if you are using something other than 
OpenOffice. 

Recommended reading:

Creating Mail Merge Documents From Text/CSV or Spreadsheets
https://wiki.openoffice.org/wiki/Documentation/How_Tos/Creating_Mail_Merge_Docu
ments_From_Text/CSV_or_Spreadsheets

Videos
OpenOffice Mail Merge Labels Part 1 Creating an Managing a Spreadsheet Address Book
http://youtu.be/Wckq11XA0LA

OpenOffice Mail Merge Labels Part 2 Registering a Database
http://youtu.be/ZWzCIaNL-48

OpenOffice Mail Merge Labels Part 3 Creating Labels
http://youtu.be/_vIIaOUP_BQ

OpenOffice Mail Merge Labels Part 4 Suppressing Blank Address2 Line
http://youtu.be/NMcTQfiJBF8

OpenOffice Mail Merge Labels Part 5 Mail Merge Controls
http://youtu.be/EYWDc8giEPo

OpenOffice Mail Merge Labels Part 6 Creating a Query
Comming soon

OpenOffice Mail Merge Labels Part 7 The Envelope Please 
http://www.youtube.com/watch?v=Ht7v4HXfkPo

How would you do this in Microsoft Office 2007 and later
https://www.youtube.com/watch?v=q9x2m_QVs4Y
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