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Introduction to Spreadsheets 
 
Spreadsheets programs are powerful tools. Spreadsheets act like a calculator by 
automatically doing calculations. Spreadsheets have many uses.  Spreadsheets are great 
for tracking personal investments, creating budgets, tracking medical expenses and 
reimbursements.  Spreadsheets are also great for small personal databases, like address 
books, inventorying your music collection, tracking your golf handicap.   
 
There are many programs for creating spreadsheets.  We are going to be using 
OpenOffice Calc but the things we are going to be learning work with many other 
spreadsheets including Microsoft Excel.  OpenOffice can be downloaded from 
http://www.openoffice.org/ free of charge although donations are always welcome and 
participating in the feedback program is encouraged..  
 
OpenOffice (OO) is a suite.  That means that OO has many different programs bundled 
together with a common look and feel.  There is a direct link to  OpenOffice Calc, in the  
Start->AllPrograms->OpenOffice folder.   
 

 
Figure 1 Open Office from the Start Menu 

 
Or we can open the suite menu by choosing OpenOffice.org from the All Programs 
menu and then selecting Spreadsheet from the Open Office suite menu.  

 
Figure 2. Open Office Suite Menu 
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When you first open that OpenOffice Calc, it presents you with an untitled document as 
shown in Figure 3. 

 
Figure 3 – Blank Spreadsheet 

The spreadsheet is divided into rows that have a number at the left of each row and 
divided into columns with letters at the top of each column.  

A cell is the fundamental element of a worksheet. This is where data is entered and where 
values are displayed. A cell address in a spreadsheet identifies the location of the cell in 
the spreadsheet. A cell address is a combination of the column letter and the row number 
of a cell, such as A2 or B16.etc. When identifying a cell by its address, the column letter 
is always listed first followed by the row number. The cell address of the example below 
is A5. 

 
Figure 4. Cell Address 

A range  is a group of cells.  A range is defined by the upper left hand cell followed by a 
colon, and then the lower right hand cell.  
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Figure 5  Range B2:C6 

 
Hint: The highlighting colors are determined by your Windows theme.  If you can’t see 
the range try changing the themes at the windows level. 
 
Formula Toolbar 

Figure 6. Formula Toolbar 

The Formula Toolbar contains the Name Box drop-down menu and a long white box 
called the Input Line. 

The Name Box contains the name of the current cell.  The Input Line contains the 
contents of the current cell.  Data can be entered directly into the spreadsheet cell or into 
the input line. 
 
Exercise 1 

Start OpenOffice Calc 
  1. Select the start button 
  2. Select all programs 
  3. Select OpenOffice.org Calc 

4. Click on various cells with the mouse 
  5.  Use the cursor arrow keys to move around the spreadsheet and observe how 
the name box changes to show the current cell. 

 
Making changes to a cell 
Hint: Use the Ctrl + the  mouse scroll wheel to adjust the size of the cell display.  
 
Editing a cell 
When you click on a cell and start typing, the original contents are overwritten.  If you 
have a long complicated formula that needs to be corrected, you can type click in the 
input area on the formula line.  Or if you prefer to make the correction in the cell,  press 
F2  function key to enter edit mode when the cell has the focus.. 
 
Deleting cell contents 
OpenOffice Calc has a delete method that is unusual.  Click on the cell or highlight the 
range of cells you want to delete and then press the Delete key.  You are presented with 
an option of what type of information you want to delete.   
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Figure 7. Delete Options 

 
ESCAPE (Esc)  
If you are typing in the wrong cell, press the Esc  key to cancel the entry and restore the 
cell to the condition before you started typing or click on the x on the formula toolbar.   

UNDO  
If you have already entered the cell data, select Edit->Undo from the menu.  The 
keyboard short cut for Undo is Ctrl + Z.  Or you  can use the undo icon on the standard 
toolbar.  The undo command can take you back several steps.     
 
Cells can contain Text 
A cell can contain up to 255 characters of alphanumeric data.  It may not all display.  By 
default the spreadsheet will continue display as much as it can until it encounters a non-
emtpy cell to the right of the cell containing the text. 
 Exercise 2 
 1) Click on cell A1 
 2) Type Text can extend beyond the boundaries of a cell and press Enter. 
 3) Click on cell B1 
 4) Type 25 press Enter 
 
Cells can contain numeric data.   
Numeric data consists of constants, expressions and dates. Unlike text, the display of 
numeric data can’t spill outside its cell.  If the value is too big to be displayed in the cell, 
######## is displayed instead. 
 

Entering a number (constant)  
When you type in a number into a cell it’s called a constant.  Do not enter commas (,) 
in your numbers.  For example 2,000 is not a number, 2000 is a number.  Most 
modern spreadsheets allows you to use $ and % signs in numerical data entry, but 
some of the simpler spreadsheets require those to be left off as well.   
 1) Click on cell A2   
 2) Type  2000  press Enter 
 3) Click on cell B2 
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 4) Type  2,000  press Enter 
Do you see the difference in alignment? 
If no special formatting has been applied to cells, numbers are always right justified 
in a cell.  If you are trying to enter a number and it appears left justified, it probably 
has characters that are not valid for numerical data. 
 
Entering a date 
A date is a special kind of number.  If you enter a partial date, your spreadsheet will 
assume it’s the current year.  Your Spreadsheet can do all sorts of calculations with 
numbers 
 1) Click on cell A3 
 2) Type Dates press Enter 
 3) Type 5/2 press Enter 
 4) Type 5/2/2010 press Enter 
 
Cells can contain Formulas  
One of the most valuable features of a spreadsheet is its value to calculate values by 
using formulas.  Formulas can range from the simple, to the extremely complex. You 
can calculate values based on numbers you type directly into the formula =1+5+2  to 
add the values 1, 5 and 2.  However the power of a spreadsheet formula in the fact 
that formulas can refer to other cells in the worksheet.  The formula = B2+B3+B4 
adds the values of the cells B2, B3 and B4.  When the values of those cells change, 
the spreadsheet automatically recalculates the value of B2+B3+B4. 
 
The spreadsheet recognizes a formula if the entry begins with an equal sign (=) or a 
plus sign(+). 
 
1) Select cell B2  
2) Type   2   press  
3) Type   4   press  
4) Type   5   press  
5.  Type   =B2+C2+D2  press Enter 
Did you notice that we could use the arrow keys to finish an entry? 
 
Instead of typing in the Cell number you can also point instead of type. 

1. Click on cell E2 
2. Type  =  press    type to select B2+ use the cursor keys to highlight 

B3  type + use the cursor keys to highlight B4  
press Enter  
 

Did you notice that when the spreadsheet is expecting an operand pointing does not exit 
the cells?  If the formula was a complete expression the cursor key exited the cell. 
 
Mathematical Operations 
A spreadsheet program can calculate formulas using addition(+) , subtraction(-), 
multiplication(*), division (/) and exponentiation(^). 
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 Exercise  
  Enter the following text and formulas into the spreadsheet 

Addition =5+2  
Subtraction = 5-2  
Multiplication =5*2  
Division =5/2  
Exponentiation  =5^2 Five squared or 52 
   

 
When you combine these operators in a formula you need to keep in mind that there is a 
mathematical order of operations.  This is something you learned in school, but may not 
have used since then.  A formula is not processed from left to right.  Mathematical rules 
require that items in inner most parenthesis are performed first, exponentiation is done 
next, multiplication and division is done, and then addition and subtraction.  The 
natural mathematical order is ( ), ^, *, / , +, -, and spreadsheet programs obey these 
rules.  
  =2+3*5    will yield 17 
  =(2+3)*5   will yield 25 
 
 
Functions 

 
Your spreadsheet program has many built-in functions.  In this class we are only going 
to use two, the Sum function, and the Round function.  You can find out more about 
the other functions in the spreadsheet’s Help documentation or by using the function 
wizard on the formula bar. 
 
The sum is such a popular function that it has its own icon on the formula bar.  The sum 
works on a range. We’ve done written a few formulas where we add a bunch of cells 
together using the + operator.  The SUM( ) function works on what we call a range. A 
range is a rectangular group of cells that can be acted on in one command.   
 = A1+A2+A3+A4   =SUM(A1:A4)  
 
When you want to add 100’s of cells together the SUM becomes a necessity.   
 
You can type a range A1:A4 or you can select a range using the mouse or the cursor 
arrows on the keyboard. 
 
To select a range with a mouse 
 1. Click one of the corner cells of the range 
 2. Drag the mouse over the range. 
 3. When you reach the other corner of the range, release the mouse button. 
To select a range with the cursor arrows 
 1.  Move to a cell at a corner of the range. 
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 2.  Press and hold down the Shift key, and press the arrows until you get to the 
end of the range. 

Practice 
1)Create this spreadsheet  or open the Class samples\Budget.xls  

 
 2) Click on cell F2 
 3) Click on the Σ icon on the formula tool bar 

4) note the spreadsheet will try to guess what you want to sum up, so B2:E2 
should already be selected. If however these are not the cells selected, press 
Delete and then highlight B2 and drag the mouse to E2 

 5)  Press Enter 
 
Extra: Create a sum for the January column. 
 

 
The Standard Tool bar 

Copy   and Paste    
The copy command works on a cell or a range of  cells.  The copy command copies a cell 
to clipboard.  The copy command can be found on the Edit menu.  Edit->Copy or you 
can click on the Copy Icon  from the standard toolbar, or you can use the keyboard 
shortcut  Ctrl+C  or we can simply right click on the cell and select copy from the 
options. 
 
 Exercise: 
 1) Select cell F1 
 2) Click on the Copy Icon 
 3) Click on cell F2 and drag the mouse down to F9  
 4) Right click and then click on the Paste Icon  
Now inspect the contents of cells F1:F9.  Do you see how the formulas changed relative 
to the cell you copied from? 
 
Extra: Copy the January Total formula, to February and March. 
 
Relative verses Absolute Addressing 
The reason all those formulas changed was because they use relative addressing.  What 
would we do if we didn’t want all or some of those cell references to change?.  Then we 
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would use an absolute address in a formula. Absolute addressing can cause the column, 
row, or both the column and row to remain the same. 
Address  
A1 This is a relative address, when the formula is copied all the addresses will 

be relative to the new location. 
$A$1 This is an absolute address, when the formula is copied all the formula will 

still reference A1 
$A1 This is an absolute address.  When the formula is copied the formula will 

still reference column A, only the row will change to be relative to the new 
location. 

A$1 This is an absolute address.  When the formula is copied, the cell will still 
refrence row 1,  only the column will be relative to the new location. 

 
A1 is a relative address.  $A$1 is an absolute address.  When it is copied, the address is 
always the same. $A1 says the column must stay the same but the row can change.  A$1 
says the column can change, but the row must stay the same. 
 
Example  
Lets make a running total for our budget. 

1. In cell A11 type Running Total   
2. In cell B11 type =SUM($B$2:B8) and press Enter 
3. Right click on cell B11 and select copy from your list of options 
4. Highlight the range C11:E11-and right click the mouse in the range and 

select paste from the options menu. 

Cut  and Paste  
The Cut and Paste commands moves a cell.  Formulas that reference the cell directly will  
be changed to reflect the new location.  Functions that use a range usually are not 
effected by a cut and paste unless the cell was the corner cell of a range.   
 Example 
 1.  Create a spreadsheet that looks like this 

  

3. Highlight cell A3 and then click on the in the toolbar. 

4. Right click on cell B3 and then click on the paste icon,   
5. Now click on cell A5 and check out the formula  
 

Note:  The keyboard shortcut for cut is Ctrl + X, the shortcut for paste is Ctrl + V 
 
Note: Inserting and deleting rows and columns can also change formulas. 
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Making it Pretty  - Formatting Cells 
One of the really nice things about spreadsheet programs is the ability to make your 
numbers look nice.  We are going to be using the formatting toolbar, but a more complete 
list of formatting options is available if you pick the Format-> Cells from the menu. 
 
 

 
Formatting Toolbar 

 

 
Practice 

1. Select cells B1:F1 
2. Click on the   to bold the selection 
3. Click on the Right justify Icon, ,  to align the column headings  
4. Select cells B2:F2 

5. Click on the add decimal places icon , , 2 times 
 

Let’s widen column A too   
1. Move the mouse over the line between A and B.  
2. When the pointer changes to show the resizing pointer  

  press and hold the left mouse button   
 3.   Drag the column to the right until the column is wide enough to fit the words. 
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More advanced formatting options can be found if you select  Format->Cells from the 
menu.  Remember when I said we couldn’t enter commas in our numbers?  Well we can 
still format the cells to display the values with commas.   

.  
Format Cells Dialog Box 

 
Formatting doesn’t effect the value 
   See for yourself 
  1 Click on cell A10. 
  2. Type =1/3 press Enter. 
  3. Select cell A10  

4. Select  Format Cells from the menu. 
5 On the Numbers tab change Decimal Places to 2 

  6. Click on cell B10. 
  7.  Type =A10*100000 press Enter. 
 
In cases where you are doing calculations that can result in decimal places you would 
need to Round the result instead of formatting the result.  In Open Office the round 
function has two arguments, the value and the number of decimals.=Round(value; # of 
decimals).  Most other spreadsheets use a comma instead of a semicolon to separate the 
arguments. 
  1. Click on cell A11. 
  2. Type =Round(A10;2) press Enter.  
  3.  Click on cell B11. 
  4. Type =A11*100000 press Enter.  
 
Printing 
Open Office 3 doesn’t use the standard Microsoft printer dialogs, so it’s a bit different to 
do your printing.  Avoid the Printer Icon on the toolbar, it prints directly to your default 
printer without presenting any printer dialog screen, and prints the entire spreadsheet ..  
The File->Print option from the dropdown menu, gives you a better print control. 
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Printer Dialog box from the menu item File->Print  

 
Print range 
There are some special considerations when printing a spreadsheet.  .  If no print area was 
defined, it will print the entire spreadsheet.  If you don’t want to print everything, you 
need to set a print range or print selected cells.  The print range is stored with the 
document, and will remain until the print range is cleared. 

To set a print range, 
1. Select the cells you want to print 
2. Choose Format->Print Ranges->Define from the menu. 
 
To clear a print range 
2. Choose Format->Print Ranges->Remove from the menu. 

 
Page Breaks 
Manual Breaks are available for both columns and rows.  A row page break is inserted 
just above the active cell.  A column page break is inserted just to the left of the active 
cell.   

To insert a row break.   Click on a cell below the last row to be included on the 
page and then select Insert->Manual Break->Row  

 

Page Preview 
It is always a good idea to preview before you print a spreadsheet.  Using the scaling tool 
you can shrink or grow the size of the print, but this is not nearly as intuitive as the print 
preview that Microsoft uses with its products. 

  
Page Preview Controls 
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The page preview controls allow you to inspect all the pages, zoom in, zoom out, fill the 
full page with the preview, but the two most important controls on this page are the 
Format Page and the Close Preview. 
 
Close Preview returns you to your spreadsheet view so don’t try to ‘x’ it out.. 
 
Format Page 
The Sheet tab from the Format Page option, allows you to select scaling options for 
your printing. 

. 
 
Saving 
When you save a spreadsheet, Open Office defaults to an ODS file type.  Keep in mind 
that we are living in a Microsoft world.  Microsoft doesn’t open ODS files.  If you are 
sharing files with other people, you should consider using the Microsoft Excel 
97/2000/XP(.xls) format.  Most spreadsheet programs will open this format.  If you 
change the Windows default file association for XLS to Open Office Calc, you can use 
the double click open method. 
 
Hint: You can set the save options to default to Microsoft Excel 97/2000/XP (.xls). 
 
Database 
Many people use a spreadsheet for a personal database.  The ability to sort items and set 
filters makes this ideal for keeping lists.   
 
Sorting 
When sorting it is important to get a range that includes all the data for a each line in the 
database. 
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Sorting Exercise 
1. Open the file called Handicap.xls 
2. Select the range A1:G22 
3. Select Data Sort from the menu 

  
 
4. From the Sort Dialog window select the Options tab  
5. Check Range contains column labels 
 

 
6. Click on the Sort Criteria Tab 
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7. Choose Sort by Course   

 
 
8. Click on OK 
 

AutoFilters 
While sorts can be handy, the setting filters is preferable if the data is already in the most 
logical order.   

 
Exercise: 
1. Open the file ClassExamples\Tunes.xls 
2. Turn on the Filters 
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3. Set the filter to Year = 1977 

     
  

 
Splitting Windows 
With a big spreadsheet like Tunes, its easy to lose track of what column is what column.  
Make sure that Auto Filter is off.before you try splitting the window. 

 
Exercise 
1.) Move to cell A2 
2.)Select Windows Split from the menu 
 
Note If you had split the window at B2 you would have frozen the row labels too. 

 
Inserting Rows and Columns 
Its easy to insert missing rows or columns.  There is an Insert->Rows and Insert -
>Column on the menu.  This is also a place where you can use a right click. 

Exercise 
1)  Scroll down to the Artist =Miller, Roger 
2)  Right click and select Insert from the list of options 
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3) From the Insert Cells dialog Box Select Entire Row and press OK 

  
4)    Create an Entry for “Miller, Glen “, “Greatest Hits”, CD, 1996  
 

 
Conclusion 
You now have some basic spreadsheet skills.  You can find more Open Office Tutorials 
at http://www.tutorialsforopenoffice.org/category_index/Index.html 
 
  


